ビルド

提供: iDempiere ja
移動先: 案内検索

はじめに

このページは、ビルドの準備が終わったあと、iDempiereをビルドする方法を記載しています。

http://www.globalqss.com/wiki/index.php/IDempiere

idempiereのソースコードの取得

TortoiseHgを使ってidempiereのソースコードを取得します。

任意の場所にフォルダを作成して、フォルダを右クリックしてください。

メニューの"TortoiseHg > Clone..."を選択してください。

"ソース"の項目に

https://bitbucket.org/idempiere/idempiere

と入力してください。

"ターゲット"の項目に保存先のフォルダが指定されていることを確認して、

"クローン(C)"ボタンを押してください。

Mercurialリポジトリのクローンが開始されます。

(この処理にはかなり時間がかかります。)


https://bitbucket.org/idempiere/idempiere

の右側にある、get source から圧縮したファイルをダウンロードすることもできます。


PC内でのクローン

idempiereをビルドするとファイルが修正されたり、リポジトリにないファイルがダウンロードされたりするのでbitbucketから取得したソースコードを保持するため、PC内でクローンします。

任意の場所にフォルダを作成して、フォルダを右クリックしてください。

(このフォルダをEclipseのワークスペースとして指定します。)

メニューの"TortoiseHg > Clone..."を選択してください。

"ソース"の項目に2でソースコードを取得したフォルダを指定してください。

"ターゲット"の項目に保存先のフォルダが指定されていることを確認して、

"クローン(C)"ボタンを押してください。

ワークスペースの設定

Eclipseを起動して、メニューから

File > Switch Workspace > Other...

を選んでください。「Workspace Launcher」ダイアログが表示されます。

idempiereのソースコードがあるフォルダを選択してOKを押してください。 (idempiereのソースコードがあるフォルダのすぐ上のフォルダを選択してください)

classesフォルダの作成

org.adempiere.ui.zk/WEB-INF/

フォルダの下にclassesフォルダを作ってください。

mkdir org.adempiere.ui.zk/WEB-INF/classes


Target Platform の設定

メニューバーから

Window > Preferences

を選択して、表示されたウィンドウで、

Plug-in Development > Target Platform

を選択してください。

Addボタンを押してください。

"Nothing: Start with an empty target definition" を選択してNextを押してください。

Nameに "Adempiere Target Platform" と入力してください。

"Locations"タブでAddボタンを押してください。

Directoryを選択して、Nextボタンを押してください。

Location:に

${workspace_loc}/targetPlatform

と入力して、"Finish"ボタンを押してください。


Plug-in Development > Target Platform ウィンドウで

"Adempiere Target Platform"

をチェックしてActiveにしてOKを押してください。

Buckminsterの実行

メニューから

File > Import > Buckminster > Materialize from Buckminster MSPEC, CQUERY or BOM

を選択してください。

Enter a URL of either MSPEC, BOM, or CQUERY (use a URL or a file system path)

org.adempiere.sdk-feature/adempiere.mspec

を選択してください。

Eclipseが依存性の確認と必要なファイルのダウンロードをします。

(この処理には時間がかかります。)

処理が終わると"Finish"ボタンが押せるようになります。

"Finish"ボタンを押すとビルド(materialize)が実行されます。

(この処理も時間がかかります。)

ビルドが完了するとEclipseの"Project Explorer"にidempiereのプロジェクト一覧が表示されます。

文字コードの変更

Eclipseプロジェクトの文字コードを変更しないとビルドエラーになります。

EclipseのProject Explorerでorg.adempiere.baseを右クリックして、Proertiesをクリックして、 プロパティウィンドウを開いてください。

ResourceのText file encodingでOtherのラジオボタンを選び、UTF-8を選択してください。

idempiereの起動(確認)

Eclipseのメニューから

Run > Run Configurations

で"Run Configurations"ウィンドウを開き、

Eclipse Application > swingclient.product

を選択して右下の"Run"ボタンを押すとidempiereのSwingアプリケーションが起動します。

※データベースサーバーの起動とデータのインポートをしていないとログインはできません。

手動でのデータのインポート

※この手順は開発者向けです。idempiereのインストーラを作成して、セットアップを完了した後は、

idempiere-server\utils\RUN_ImportIdempiere.bat を実行することでデータをインポートできます。

idempiereのソースコードを置いたフォルダにある、

org.adempiere.server-feature\data\seed

にデータベースのダンプデータが入っています。

PostgreSQLを起動して、コマンドプロンプトから以下のコマンドを実行してください。

@REM adempiereロールの作成
psql -U postgres -c "CREATE ROLE adempiere SUPERUSER LOGIN PASSWORD 'adempiere'"
@REM idempiereデータベースの作成
createdb  --template=template0 -E UNICODE -O adempiere -U adempiere idempiere
@REM search_pathの追加
psql -d idempiere -U adempiere -c "ALTER ROLE adempiere SET search_path TO adempiere, pg_catalog"
@REM データのインポート($IDEMPIERE_REPOSITORY はidempiereのソースコードを置いたフォルダです。)
cd $IDEMPIERE_REPOSITORY
jar xvf $IDEMPIERE_REPOSITORY/org.adempiere.server-feature/data/seed/Adempiere_pg.jar
psql -d idempiere -U adempiere -f Adempiere_pg.dmp