Übersetzung in iDempiere anpassen

Aus iDempiere de
Wechseln zu: Navigation, Suche

Ziel dieser Seite

Diese Seite beschreibt Schritt für Schritt die Anpassung von iDempiere an eine entsprechende Landessprache. Diese Beispiel beschreibt die Anpassung von iDempiere an die deutsche Sprache.


Note.gif Notiz:

Die Anpassung ist relativ einfach, da iDempiere bereits alle Möglichkeiten der Sprachanpassung enthält.



Kurzbeschreibung

Anmeldung als <SuperUser> (Passwort bei Standardinstallation = <System>) Toolbar → Extras → Einstellungen

Haken bei <Übersetzungsregister anzeigen> setzen

Sprachversion installieren oder eine neue Sprachdatei erzeugen.

Für die Übersetzungsart das entsprechende Übersetzungsfenster auswählen:

Menüpunkte: Menü → Systemadministration → Einstellungen allgemein → Einstellungen System → Menü
Formulare: Menü → Application Dictionary → Formular
Feldbeschriftungen: Menü → Application Dictionary → Mitteilungen
Fenstertitel, Register, Feldbeschriftungen: Menü → Application Dictionary → Fenster, Register & Felder
Knopf in einem Fenster: Menü → Application Dictionary → Report & Prozess
Workflow: Menü → Einstellungen allgemein → Workflow → Workflow

Englischen Eintrag auswählen

Übersetzungsregister aktivieren

benötigte (deutsche) Übersetzung auswählen

Übersetzung eingeben

Änderungen speichern

Ggf. Neustart von iDempiere

Grundlagen

iDempiere wurde extrem einheitlich und übersichtlich programmiert. Dies ist die richtige Stelle ein großes Lob an die Entwickler auszusprechen.
Diese Einheitlichkeit spiegelt sich z.B. in vielen mehrfach verwendeten Felder wieder.
Ein Beispiel dafür ist z.B. das Feld "Nutzer". Dieses Feld trägt in der Tabelle den Namen AD_User_ID und wird in der aktuell installierten Version in 99 Tabellen und 14 mal als Prozessparameter eingesetzt.
AD_User_ID Tabellenansicht
AD_User_ID Tabellenansicht

Nun bietet iDempiere zwei verschieden Möglichkeiten die Übersetzung durchzuführen:


Zentrale Übersetzung die in alle Fenster / Prozesse usw. übertragen wird

Um bei unserem Beispiel des "Nutzers" zu bleiben müsste die Übersetzung in 99 verschiedenen Eingabemasken erfolgen. Dies ist sicherlich nicht sehr effektiv die Übersetzung ohne weitere Hilfsmittel durchzuführen.
Aus diesem Grund bietet iDempiere eine Zentrale Verwaltung für Übersetzungen an. Dies wird in einigen Bildschirmmasken durch einen Haken bei "Zentral verwaltet" gesteuert.

Die folgenden Bildschirmseiten zeigen einige Beispiele für den Einsatz der "Zentralen Verwaltung", aber auch einige Bildschirmseiten, die diese Möglichkeit nicht bieten:

Menü - Menü - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png Menü - Übersetzung - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png Fenster, Register & Feld - Fenster - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png Fenster, Register & Feld - Übersetzung Fenster - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png Fenster, Register & Feld - Register - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png Fenster, Register & Feld - Übersetzung Register - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png Fenster, Register & Feld - Feld - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png Fenster, Register & Feld - Übersetzung Feld - Fenster, Register & Feld - Fenster (iDempiere 1.0.0).png

Feldbezeichnungen im Fenster Element bearbeiten

Alle Feldbeschriftungen befinden sich in der Tabelle Element. Diese Tabelle enthält zur Zeit ca. 3800 Tabelleneinträge. Aus diesem Grund wird hier das Fenster Eintrag suchen vorgeschaltet. In diesem Fenster kann eine Vorauswahl "Filterung" der Datensätze erfolgen.



Individuelle Übersetzung für ein bestimmtes Fenster / Prozess...

Vorbereitung

Zunächst sollten Sie eine bereits vorhandene Sprachversion installieren oder eine neue Sprachdatei erzeugen.

Anschließend werden in den Einstellungen die Übersetzungsregister einzelner Fenster eingeblendet.

Toolbar → Extras → Einstellungen

Einstellungen


Caution.gif Achtung!

Die Änderungen werden erst nach einer Neuanmeldung bei iDempiere sichtbar

Um eine einheitliche Übersetzung zu gewährleisten wird das Glossar ständig weiter ausgebaut. Im Glossar können zu den englischen Begriffen oder Texten die deutschen Übersetzungen aufgefunden werden. Ergänzungen oder Verbesserungen der bisherigen Begriffe sind herzlich willkommen.



Übersetzung starten

Übersetzungen können nicht als Benutzer oder Admin verändert werden. Hierzu ist die Anmeldung als SuperUser erforderlich.

Anmeldung:

  • Benutzer: <SuperUser>
  • Passwort: <System> (oder Ihr bereits geändertes Passwort)



Menüpunkt übersetzen

Wir werden nun den Menüpunkt Reset Password (sichtbar bei der Anmeldung als Admin) in Passwort zurücksetzen verändern .

Menüpunkt: Reset Password

Menüpunkte werden in dem Fenster Menü angepasst.


Menü → Systemadministration → Einstellungen allgemein → Einstellungen System → Menü


Menüpunkt - Menü

Nach dem Aufruf des Fensters wählen wir den zu ändernden Eintrag <Reset Password> in der linken Baumstruktur aus.

Reset Password auswählen

Nun wird die zu ändernde deutsche Sprachversion aus den bereits installierten Sprachversionen ausgewählt.

Deutsche Sprachversion aus Tabelle Reset Password auswählen

Und mittels Icon MultiX24.png in die Einzelansicht umgeschaltet.

Deutsche Sprachversion anpassen

Die Änderungen werden vorgenommen.

Deutsche Sprachversion anpassen

Durch einen Klick auf Icon Save24.png oder <F4> werden die Änderungen gespeichert.


Caution.gif Achtung!

Die Änderungen werden bei der nächsten Neuanmeldung bei iDempiere sichtbar

Menüpunkt: Passwort zurücksetzen

Nun haben wir erfolgreich einen Menüpunkt angepasst. Üblicherweise sind die Fenster und der aufrufende Menüpunkt identische benannt. Aus diesem Grund wird im nächsten Schritt der Fenstername angepasst.



Formular übersetzen

In dem Fenster Menü ist ersichtlich um welche Art von Aufruf es sich handelt:

  • Aufgaben
  • Fenster
  • Formular
  • Report
  • Vorgang
  • Workbench
  • Workflow

Bei dem Menüpunkt <Reset Password> handelt es sich, wie im folgenden Fenster erkennbar ist, um ein Formular.

Reset Password auswählen


Für die Übersetzung wird über den Menüpunkt Menü → Application Dictionary → Formular das Fenster zur Formularbearbeitung geöffnet.

Formular Reset Password auswählen

In der Tabellenansicht des Karteireiters <Übersetzung> wird die deutsche Sprache <German (Germany)> ausgewählt und zur Bearbeitung mit dem Symbol Icon MultiX24.png der Symbolleiste in die Einzelansicht umgeschaltet.

Die entsprechende Übersetzung eingegeben und der Datensatz mittels Icon Save24.png oder <F4> gespeichert.

Übersetzung Reset Password auswählen


Note.gif Notiz:

Diese Änderungen sind sofort bei einem neu geöffnetem Fenster sichtbar. Ein Neustart oder eine Neuanmeldung bei iDempiere ist nicht erforderlich


Beschriftungen von Feldern übersetzen

Beispielfenster ohne Übersetzung

In Datenmasken sind den Eingabefeldern meistens Textbeschriftungen vorangestellt. Diese Beschriftungen können durch den SuperUser ebenfalls übersetzt werden.

Der Menüpunkt Menü → Application Dictionary → Mitteilungen öffnet das folgende Fenster in dem die entsprechende Mitteilung aufgerufen wird:


Note.gif Notiz:

Kleiner Tipp:

Obwohl eine englische Beschriftung vor dem Feld angezeigt wird handelt es sich evtl. um eine Übersetzung. In diesem Fall wird der Suchbegriff evtl. nicht gefunden. Daher bitte %Kurzbegriff% verwenden. Der Kurzbegriff kann ein besonderes Wort aus der Zeichenkette sein.

Original Text heraussuchen

Aus der Liste wird die deutsche Sprache auswählt und mittels Icon MultiX24.png in die Maskenansicht umgeschaltet.

Mitteilungen - Übersetzung - Tabellenansicht - Old Password - Fenster (iDempiere 1.0.0).png

In diesem Fenster wird die neue Mitteilung <Altes Passwort> eingegeben und die Änderungen durch Icon Save24.png oder <F4> gespeichert.

Mitteilungen - Übersetzung - Altes Passwort - Fenster (iDempiere 1.0.0).png

Passwort zurücksetzen - Nur Altes Passwort übersetzt - Fenster (iDempiere 1.0.0).png


Caution.gif Achtung!

Die Änderungen werden beim nächsten Neustart von iDempiere sichtbar


Fenstertitel, Register und Felder übersetzen

Wie bereits im Bereich Formular übersetzen beschrieben könne auch Fenster und Fenstertitel übersetzt werden.

An dem Beispiel „Gruppe Geschäftspartner → Geschäftspartnergruppe„ wird gezeigt wie die Überschriften für Eingabefenster bearbeitet werden können.

Der Menüpunkt Menü → Application Dictionary → Fenster, Register & Felder öffnet zunächst das „Eintrag suchen“ Fenster. Da es sehr viele Fenster in iDempiere gibt sollte zunächst die Auswahl der Fenster auch eine überschaubare Menge begrenzt (gefiltert) werden.

Eintrag nach Business filtern

Wie bereits oben auf dieser Seite beschrieben wird das Übersetzungsregister ausgewählt und die entsprechenden Änderungen durchgeführt. Das Ergebnis wird durch Icon Save24.png oder <F4> gespeichert.

Fenster Geschäftspartnergruppe bearbeiten


Anschließend wird ein Register ausgewählt.

Register auswählen

Die entsprechende Übersetzung kann, nach Auswahl der entsprechenden Sprache, in dem Fenster Übersetzung Register erfolgen.

Fenster, Register & Feld - Übersetzung Register - Geschäftspartnergruppe - Fenster (iDempiere 1.0.0).png

Auch die Felder in einem Register können übersetzt werden. Hierzu wird zunächst das entsprechende Register und anschließend das zu übersetzende Feld ausgewählt.

Fenster, Register & Feld - Feld - Tabelle - Geschäftspartnergruppe - Fenster (iDempiere 1.0.0).png


Die entsprechende Übersetzung kann, nach Auswahl der entsprechenden Sprache, in dem Fenster Übersetzung Feld erfolgen.

Fenster, Register & Feld - Übersetzung Feld - Geschäftspartnergruppe - Fenster (iDempiere 1.0.0).png


Workflow übersetzen

Auch die Texte in einem Workflow können direkt in iDempiere übersetzt werden. Grundsätzlich muß hierzu das Fenster "Workflow" verwendte werden.
Grundsätzlich gibt es (mindestens) zwei verschiedene Wege das Fenster "Worklfow" aufzurufen.

Hier zunächst der "umständliche" Weg über den "Workflow-Editor". Dieser Weg wird beschrieben um zu zeigen, dass es auch direkt aus dem Workflow-Editor heraus möglich ist das Fenster "Workflow" zo erreichen.
Menü → Einstellungen allgemein → Workflow → Workflow-Editor
Zunächst wird der entsprechende Workflow ausgewählt:

Workflow-Editor WorkflowFensterLeer.png Workflow-Editor WorkflowFensterAuswahl.png



In dem folgenden Fenster wird einfach durch einen einfachen Kick (kein Rechtsklick) auf Artikel Workflow-Editor EinrichtungSteuer.png


Achtung: Bei einer Anmeldung als "Admin" stehen Ihnen nur folgende Punkte zur Verfügung:
Workflow-Editor EinrichtungSteuerKontextArtikel.png


Achtung: Bei einer Anmeldung als "System" stehen Ihnen alle Punkte zur Verfügung:
Workflow-Editor EinrichtungSteuerKontextArtikelAlsSystem.png


Für die Zoom Funktion benötigen wir alle Rechte der Rolle System. Durch Auswahl der Zoom Funktion gelangen Sin nun direkt in das "Workflow" Fenster und rufen automatisch den richtigen Punkt auf.


Der kürzere und direkte Weg ist über folgenden Menüpunkt verfügbar:
Menü → Einstellungen allgemein → Workflow → Workflow

Hier haben Sie jedoch den Nachteil , dass Sie den entsprechenden Workflow und den Workflow Knoten selbst aufrufen müssen.


Übersetzung:
Damit die Übersetzung im nächsten Fenster "Knotenübersetzung" seine Wirkung zeigt sollten Sie den Haken bei "Zentral verwaltet" entfernen.
WorkflowKnoten EinstellungSteuern NichtZentralVerwaltet.png


WorkflowKnotenKnotenübersetzung EinstellungSteuern Artikel.png


Bei diesen Einstellungen wird die Übersetzung im Fenster "Workflow-Editor" sichtbar.